Thứ Bảy, 22 tháng 6, 2013

Dynamic Multipoint VPN


Sử dụng tính năng Dynamic Multipoint VPN (DMVPN) để kết nối tất cả các điểm của khách hàng khác nhau về mạng ISP.



Mô hình


Nhiệm vụ:
- Cấu hình DMVPN đảm bảo các khách hàng có thể ping thấy interface loopback của Router ISP.
- Chạy định tuyến EIGRP giữa mạng ISP và network khách hàng.
- Đảm bảo các khách hàng với nhau không tự động thiết lập neighbor.


Cấu hình Router Cisco phía mạng ISP
R1#sh run
!
hostname R1
!
ip cef
ip tcp synwait-time 5
no ip domain lookup
!
crypto isakmp policy 1
encr 3des
hash md5
authentication pre-share
group 2
crypto isakmp key 6 cisco address 0.0.0.0 0.0.0.0
!
crypto ipsec transform-set transform esp-3des esp-md5-hmac
!
crypto ipsec profile cryptoipsec
set security-association lifetime seconds 120
set transform-set transform
!
interface Loopback1
ip address 192.168.1.1 255.255.255.0
!
interface Tunnel0
ip address 11.11.11.11 255.255.255.0
no ip redirects
ip next-hop-self eigrp 1
ip split-horizon eigrp 1
ip nhrp authentication cisco
ip nhrp map multicast dynamic
ip nhrp network-id 1
ip nhrp holdtime 600
tunnel source FastEthernet0/0
tunnel mode gre multipoint
tunnel key 123
tunnel protection ipsec profile cryptoipsec
!
interface FastEthernet0/0
ip address 1.1.1.1 255.255.255.0
duplex auto
speed auto
!
router eigrp 1
network 11.11.11.0 0.0.0.255
network 192.168.1.0
no auto-summary

Cấu hình Router Cisco phía khách hàng A

R2#sh run
hostname R2
!
ip cef
crypto isakmp policy 1
encr 3des
hash md5
authentication pre-share
group 2
crypto isakmp key 6 cisco address 0.0.0.0 0.0.0.0
!
crypto ipsec transform-set transform esp-3des esp-md5-hmac
!
crypto ipsec profile cryptoipsec
set security-association lifetime seconds 120
set transform-set transform
!
interface Loopback1
ip address 192.168.2.1 255.255.255.0
!
interface Tunnel0
bandwidth 64
ip address 11.11.11.12 255.255.255.0
no ip redirects
ip nhrp authentication cisco
ip nhrp map multicast dynamic
ip nhrp map 11.11.11.11 1.1.1.1
ip nhrp map multicast 1.1.1.1
ip nhrp network-id 1
ip nhrp holdtime 600
ip nhrp nhs 11.11.11.11
tunnel source FastEthernet0/0
tunnel mode gre multipoint
tunnel key 123
tunnel protection ipsec profile cryptoipsec
!
interface FastEthernet0/0
ip address 1.1.1.2 255.255.255.0
duplex auto
speed auto
!
router eigrp 1
network 11.11.11.0 0.0.0.255
network 192.168.2.0
no auto-summary
!
Cấu hình Router Cisco phía khách hàng B
R3#
R3#sh run
hostname R3
!
ip cef
!
crypto isakmp policy 1
encr 3des
hash md5
authentication pre-share
group 2
crypto isakmp key 6 cisco address 0.0.0.0 0.0.0.0
!
crypto ipsec transform-set transform esp-3des esp-md5-hmac
!
crypto ipsec profile cryptoipsec
set security-association lifetime seconds 120
set transform-set transform
!
interface Loopback1
ip address 192.168.3.1 255.255.255.0
!
interface Tunnel0
bandwidth 64
ip address 11.11.11.13 255.255.255.0
no ip redirects
ip nhrp authentication cisco
ip nhrp map multicast dynamic
ip nhrp map multicast 1.1.1.1
ip nhrp map 11.11.11.11 1.1.1.1
ip nhrp network-id 1
ip nhrp holdtime 600
ip nhrp nhs 11.11.11.11
tunnel source FastEthernet0/0
tunnel mode gre multipoint
tunnel key 123
tunnel protection ipsec profile cryptoipsec
!
interface FastEthernet0/0
ip address 1.1.1.3 255.255.255.0
duplex auto
speed auto
!
router eigrp 1
network 11.11.11.0 0.0.0.255
network 192.168.3.0
no auto-summary



Writer: Vigorous.nguyen
Reference: www.cisco.com

Không có nhận xét nào:

Đăng nhận xét